Commit 0bd0b511 authored by Venkat Malladi's avatar Venkat Malladi
Browse files

Fix conda env.

parent 1a113905
Pipeline #6599 failed with stage
in 3 seconds
before_script: before_script:
- module load python/3.7.x-anaconda - module load python/3.7.x-anaconda
- pip install --user pytest-pythonpath==0.7.1 pytest-cov==2.5.1 - conda env create -f environment.yml
stages: stages:
- unit - unit
...@@ -8,4 +8,5 @@ stages: ...@@ -8,4 +8,5 @@ stages:
unit_tests: unit_tests:
stage: unit stage: unit
script: script:
- conda activate kce_etl
- pytest -m unit --cov=./scripts - pytest -m unit --cov=./scripts
...@@ -2,9 +2,11 @@ name: kce_etl ...@@ -2,9 +2,11 @@ name: kce_etl
channels: channels:
- defaults - defaults
dependencies: dependencies:
- attrs=19.3.0
- blas=1.0 - blas=1.0
- ca-certificates=2020.1.1 - ca-certificates=2020.1.1
- certifi=2020.4.5.1 - certifi=2020.4.5.1
- importlib_metadata=1.5.0
- intel-openmp=2019.4 - intel-openmp=2019.4
- libedit=3.1.20181209 - libedit=3.1.20181209
- libffi=3.2.1 - libffi=3.2.1
...@@ -12,12 +14,18 @@ dependencies: ...@@ -12,12 +14,18 @@ dependencies:
- mkl-service=2.3.0 - mkl-service=2.3.0
- mkl_fft=1.0.15 - mkl_fft=1.0.15
- mkl_random=1.1.0 - mkl_random=1.1.0
- more-itertools=8.2.0
- ncurses=6.2 - ncurses=6.2
- numpy=1.18.1 - numpy=1.18.1
- numpy-base=1.18.1 - numpy-base=1.18.1
- openssl=1.1.1f - openssl=1.1.1f
- packaging=20.3
- pandas=1.0.3 - pandas=1.0.3
- pip=20.0.2 - pip=20.0.2
- pluggy=0.13.1
- py=1.8.1
- pyparsing=2.4.6
- pytest=5.4.1
- python=3.6.10 - python=3.6.10
- python-dateutil=2.8.1 - python-dateutil=2.8.1
- pytz=2019.3 - pytz=2019.3
...@@ -26,6 +34,8 @@ dependencies: ...@@ -26,6 +34,8 @@ dependencies:
- six=1.14.0 - six=1.14.0
- sqlite=3.31.1 - sqlite=3.31.1
- tk=8.6.8 - tk=8.6.8
- wcwidth=0.1.9
- wheel=0.34.2 - wheel=0.34.2
- xz=5.2.5 - xz=5.2.5
- zipp=2.2.0
- zlib=1.2.11 - zlib=1.2.11
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment